Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.

Can't join any multiplayergames?

Recommended Posts

Hey fellas!


Well, i was a longtime player of TDU 1 but other things came in between so i just got hold of TDU2. I'm not really happy about this...I can't join any multiplayergames! Is it because my NAT settings are "Strict: Symmetric"? I've tried every guide to get the NAT to change (opening ports etc etc) but it refuses to work. Is that why i can't join multiplayerraces?


I've tried them all, ranked, unranked, whatever...Any ideas?



Share this post

Link to post
Share on other sites

Could be, possibly. I can hardly ever join any either, but I've started believing that the game just lies and tells me there are races when there aren't. TDU1 did the same thing. It takes a while but when I find a game that actually exists I usually don't have any problems joining. I think I've been able to with Strict NAT settings too.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...