Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.
datsunsss

TDU on Windows 10

Recommended Posts

Tried all these methods, nothing worked for me.. damn. Hopefully something else comes up.

 

I'm dual-booting W10 and W7.. that worked :lol: It's probably the only solution, unfortunately. Not hard to do though. :)

Share this post


Link to post
Share on other sites

Dvd drive boots up and comes up as loading on pc. Then just stops... Yet I go to task manager and there is tdu listed as running and using like 40% of cpu. Game then launches too black screen 5 mins later then get an error message and the game crashes

Share this post


Link to post
Share on other sites
Dvd drive boots up and comes up as loading on pc. Then just stops... Yet I go to task manager and there is tdu listed as running and using like 40% of cpu. Game then launches too black screen 5 mins later then get an error message and the game crashes

 

Yup, that's securom! I was having the same issue. If you want to try a few suggestions that people have made in this thread and see if anything works, unfortunately for me the only answer was to dual-boot with Windows 7... but at least I have a reason to use Windows 7 again :lol:

Share this post


Link to post
Share on other sites
GUYS I FIGURED IT OUT! SHOULD WORK FOR EVERYBODY NOW. Every time before you run the game you have to turn off "Disable display scaling with DPI". Then BOOM! You are good to go!! No need for all the extra stuff i think.

 

I ran the troubleshooter and siad there was display issues. It changed a setting to with DPI and now the game runs! This is the fix for windows 10

Share this post


Link to post
Share on other sites

Switched to W10 last week and it worked great at first run.

I guess I had right display settings etc. already - must be because I just migrated from working W7 install.

 

If useful, I've been running it for years with daemon tools and a fake ISO mounted onto SCSI drive (keeping original DVD in safe location).

Share this post


Link to post
Share on other sites
GUYS I FIGURED IT OUT! SHOULD WORK FOR EVERYBODY NOW. Every time before you run the game you have to turn off "Disable display scaling with DPI". Then BOOM! You are good to go!! No need for all the extra stuff i think.

 

I ran the troubleshooter and siad there was display issues. It changed a setting to with DPI and now the game runs! This is the fix for windows 10

 

Yep thanks guys, this worked to get my TDU back up and running after finally switching to 10. No cracks or other fixes needed!

Share this post


Link to post
Share on other sites
quote_icon.png Originally Posted by acevt06»

GUYS, I FIGURED IT OUT! SHOULD WORK FOR EVERYBODY NOW. Every time before you run the game you have to turn off "Disable display scaling with DPI". Then BOOM! You are good to go!! No need for all the extra stuff i think.

quote_icon.png Originally Posted by dars »

I ran the troubleshooter and said there were display issues. It changed a setting to with DPI and now the game runs! This is the fix for windows 10

 

Yep thanks, guys, this worked to get my TDU back up and running after finally switching to 10. No cracks or other fixes needed!

 

I tried the above today and the game launches now and gets through the intro screens, and just after showing the Test Drive Unlimited screen it crashes back to the desktop... :cry:

 

I just want to play this game again! Lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...