Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.
Sign in to follow this  
Dextcloud

How to remove completely the gaps in audacity ?

Recommended Posts

Hi,

I don't know if i will make more sound mods because i can't find the time for it. But, untill now, i have still some gaps in my sound mods. I try to have good loops in my samples but i think Audacity adds a gap each time i have finished with my sample.

 

I already tried the option "trim silence". IS there a way to remove completly theses gaps ?

[ATTACH]27929[/ATTACH]

Share this post


Link to post
Share on other sites

Ha !!!

 

My bad guys, taught it was a editing shortcut problem, yeah... its the fault of audacity, if your using the free version it will create gaps at the end, I would recommend maybe get GlodWave and edit them whit this instead ? that is the program i use personally for my audio editing.

Share this post


Link to post
Share on other sites

Audacity only can could work, i don't know if they changed it by now, minimum in 16 bit mode. Exporting to 4 bit will ad this space. Solution is simple and very clever found by myself :-p. Reimport the file like you did to show us. you've got to find the common divisor of both formats, then the file having the same lengh in both formats. To find it, without changing the tempo too much, lay them both the 16 bit file and the 4 bit file over each other. If the 4 is smaller than the 16, select in the 16 a little bit less but still bigger than the 4, export and reimport and compare again. If the content of the 4 is being more moving towards the 16, thats an improvement. Normally this improvement only takes place one time before getting bigger than the 16. When improved, you need to adjust the tempo of the 16 bit exactly till it is fitting the 4 bit. Then export, reimport, should be the same lengh. They share the same lengh to format to amount of bits relativity now, like 4 is in between 2 and 8 when multiplying with 2. Sort of. This way you can keep the file you worked the clean loop out for, and don't have to change the tempo too much. Also in audacity i recommend to set the project format you are working with, BEFORE you start working with a file, not changing the bitformat in between the work, as it clearly remembers the projects attributes in some aspects, allthough you changed it later on maybe. Glad to help. Peace.

Share this post


Link to post
Share on other sites

Milli : i tried the free trial of adobe Premiere pro : what a program ! I could not work with it ! Impossible to understand how it works ! There is so much options and stuff in it !

DJ_Edyo : I don't know if it will work with goldwave. FOr the moment, i don't want to pay a software if i'm not sure it will work.

 

Thank you Djoytinnio.

Hmm ok, my setting in Audacity was 32 bits.

OK. With a newly recorded sample for the onlow.wav, the 4 bits saved is different and seems a little longer.

 

See the image below :[ATTACH]28926[/ATTACH]

Share this post


Link to post
Share on other sites

I had this thing too when opening the vanilla file, BOTH in Audacity and Sony Vegas. Weird thing is that if I don't touch the gap in audacity, it renders silent but in Sony Vegas, it leaves a nasty high-pitch static.

 

My problem is that whatever I do, it always leaves a very loud pop/click/crack sound at the looping point of every sound I edit. And I'm even not introducing any new sounds, I only wanted to pitch down the vanilla SLK mid and high sounds because they are pitched too high and do not match with the lower rev band. If anybody has had this problem and successfully overcome this, then perhaps you could share your tips. Maybe it is connected to the "gap" somehow?

Share this post


Link to post
Share on other sites

I see. Only the thing is that I have tried everything I can think of. First I tried simply deleting the gap but that did not help.

Then I zoomed in to the beginning and to the ending of the track and tried to match the phases so it would complete the wave

but that didn't work either. Finally I added fade in to the beginning and fade out to the ending but still loud and clear cracking,

popping and clicking. I'm starting to think there is something else to it.

Ah also, I also pitched down the "offmid" and "offhigh" sounds but they loop perfectly.

 

P.S. I have successfully created loops of car sounds for a game called Rigs of Rods in the past so I would expect myself to have

some idea about what I'm doing.

 

Update:

 

This really gets on my nerves so I examined the files and discovered this:

[ATTACH]28959[/ATTACH]

 

When rendering, both in Audacity and Sony Vegas, the program for some reason adds a segment of the beginning of the track

to the end of the track and that is where the "pop" is coming from. As you can see in the picture, the top channel is what I ordered

to be rendered and the bottom one is the rendered file. As to WHY it is happening, I am not sure but it might have to do with some

source and render settings conflicting with each other.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...