Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.
Sign in to follow this  
Diablo

Chrome Version 57.0.2987.133 (64-bit) causing ERR_BLOCKED_BY_XSS_AUDITOR error

Recommended Posts

UPDATE: Adding the recommended fix mentioned in post #3 has resolved this until the Chromium developers sort it out, hopefully.

 


ORIGINAL POST:

 

A rather annoying little bugger of an error is showing itself for many Chrome users who go about their internet usage as they have always done. This error that shows up when the user tends to be entering in details to a textarea or the like, is a security measure meant to stop XSS (Cross-Site Scripting) that hackers and unscrupulous sorts utilise to snatch important personal details and info from users.

 

chrome57-xssauditor-error_2.jpg

 

However it is also flagging up innocent actions such as using online forms with WYSIWYG (What You See Is What You Get) editors and embedded items that use scripts to display their retrieved contents (such as tweets) as incidences of this. And if you are posting a new thread or reply on here when using the WYSIWYG editor then unfortunately you may receive this error. :( More often than not the issue arises if a link to something on the originating domain (ie forum.turboduck.net) is included, so if you need any of those in your posts/threads then make sure to switch to the Standard editor and it should process properly.

 

chrome57-xssauditor-error.jpg

 

From some testing I have done myself it doesn't always occur and tends to happen when a link is present in the contents of the editor.

 

Post made in WYSIWYG editor: (will Preview and Post fine)

 

chrome57-xssauditor-error_3.jpg

 

Link added to Post made in WYSIWYG editor: (will cause ERR_BLOCKED_BY_XSS_AUDITOR error)

 

chrome57-xssauditor-error_4.jpg

 

Interestingly, it does not appear to show if you click the A/A (Switch Editor to Source Mode) button/icon to switch the editor to the standard editor.

 

Change Editor mode to standard: (will Preview and Post fine)

 

chrome57-xssauditor-error_5.jpg

 

This issue has been reported to the Chromium developers but from the last few replies to it they see it as doing what it is meant to and have marked it as a WontFix. Funny enough the issue was brought up by a developer of XenForo and a search for others impacted by this are plentiful. There is a method to stop it happening whereby you can tell Chrome to shut off this protection but seeing as things worked before, this seems something of a last resort to look into doing.

 

Test: Driving Racing Games | turboduck Forum

Share this post


Link to post
Share on other sites

Version 58.0.3029.81 of Chrome is out now and seems to not be suffering from this. :)

 

Okay... maybe not. Damnit! :dmad:

 

Driving Racing Games | turboduck Forum

 

Okay tested a workaround recommended by a Xenforo developer and that seems to be working now. Looks like it's basically putting this setting back to what it was before it was strengthened in the problematic v57, that now results in cases of false positives like the original post mentions.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...