Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.

Recommended Posts

Hi, I'm sorry but I can't find anything about it and the fixes I found online don't work. The game works so well, but I can't see other players for most of the time and, when I see them,  their name is white and they're not moving (except for one or two of them in Red). I want to play with my friends but we can't even meet up... How can I solve this...?

Edited by LekeSaga
Link to comment
Share on other sites

12 hours ago, LekeSaga said:

Hi, I'm sorry but I can't find anything about it and the fixes I found online don't work. The game works so well, but I can't see other players for most of the time and, when I see them,  their name is white and they're not moving (except for one or two of them in Red). I want to play with my friends but we can't even meet up... How can I solve this...?

Sounds like you need to forward your ports. Check the FAQ here:

https://turboduck.net/guide/test-drive-unlimited-r3/

Edited by TDU Iceman
Link to comment
Share on other sites

  • 2 weeks later...
On 3/27/2020 at 8:34 PM, okar19 said:

Got a question.

 

I dont want to lose my cars so once I replace files will it work? Also if something goes wrong, once I put old files back everything should be as it was before replacing files?

I would say make a new profile for TDU Platinum and keep your current one for vanilla. Also it would be easier to just backup the vanilla install and revert back if you need to later.

Link to comment
Share on other sites

Thank you! 

 

Here is the same link to help people download it quicker as took me ages to find DL link so for people like me who need this link ASAP go here >> 

https://drive.google.com/open?id=12YSgZWjb9n3CcRA1EA7hjEGcZpqpmXh2

P.s work smart, work fast! 

P.ss If you want to learn how me and you aren't so different then feel free to drop me a PM.

Got some exciting news coming up! 

 

 

 

Edited by Trustuk
Link to comment
Share on other sites

I had some issues with TDU Platinum these days, yesterday I found out how to make an online account on TDU Platinum, because I found out that you need GameSpy account which nobody can make because they were shut down. I made an online game account but I could not connect to the servers. Today I started the game, and game managed to connect to server, there are players on the map, but however when I fast travel to any player there is a car that's not moving, and when I enter the map, and get back to game again the player's car is not there and when i get back to map again player is somewhere else, they are teleporting. I searched this entire site's comments and found no solutions besides one guide that says that I should open some ports on router and firewall which I don't know how to, I tried and it didn't work. I tried to open ports on router and disabling entire firewall and it solved nothing, it only got worse. Now there are no players in the game, but there are player icons on the map. Someone need to make exact tutorial on how to do this or to make some kind of patch for that. I don't know what else to do, I'm frustrated. Sorry for bad English and typing mistakes if there are any.

Link to comment
Share on other sites

Hmm... So for some reasons now, I don't have any traffic cars showing up. Like at all. They're not invisible. Just not there. Tried the original 1.12 database in case I had fucked something up trying to get cars in, but no. They're not there as well. I do see other players. Well, when there are other online that is. Any idea why I don't see the traffic anymore?

Link to comment
Share on other sites

On 3/11/2020 at 10:49 PM, TDU Iceman said:

Sounds like you need to forward your ports. Check the FAQ here:

https://turboduck.net/guide/test-drive-unlimited-r3/

Uh, thanks for you advice lol. Anyway, my router does not support port forwarding, I know it's probably impossible, but is there a way to solve this problem without doing It?

Link to comment
Share on other sites

Hi guys.
I have some interesting issue. 
I installed the game from CD, with original CDKey, MegaPack and 1.66A Patch. 
Then, mod with Platinum 1.12 Patch, HD pack from platinum mod.
Started the game with new profile, ale game loops on loading screen. 
Today, reinstall everything, start game, leave loading screen for 8h and nothing happends. 
Can someone help my fix this? 

Link to comment
Share on other sites

  • Milli changed the title to [RELEASED] Test Drive Unlimited Platinum - v1.21

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...