Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.
Milli

[RELEASED] Test Drive Unlimited Platinum

Recommended Posts

Hi everyone! I have a problem with  white colors in game. I already asked for help on this forum discord server but no one knew how to fix this. White color is too bright.I tried turning on/off hdr but it didn't helped.  I think its problem with bloom in enb config file but i don't know what to change in it .Thanks in advance!

e.PNG

Share this post


Link to post
Share on other sites

Theres a lot of good tips in this thread that should probably be compiled in an FAQ or wiki by now.

4 gb patch for crashing, frame drops
x360ce and DS4windows for gamepad issues
G27 fix for wheels
Borderless Gaming app for alt tabbing (prevents black screen iirc)
Enble vsync, capping fps to 60 to prevent traffic bug

And probably a lot of other things I can't recall atm

Share this post


Link to post
Share on other sites
8 minutes ago, TDU Iceman said:

Theres a lot of good tips in this thread that should probably be compiled in an FAQ or wiki by now.

4 gb patch for crashing, frame drops
x360ce and DS4windows for gamepad issues
G27 fix for wheels
Borderless Gaming app for alt tabbing (prevents black screen iirc)
Enble vsync, capping fps to 60 to prevent traffic bug

And probably a lot of other things I can't recall atm

I will be adding wiki style guide in Wiki, then everyone can participate editing it, so people don't have to keep repeating same answers

I will give you a shoutout once done, not much but I can give you VIP as reward if you can help editing and promoting within the site

we are also getting lot of questions in discord, it will help to give them a direction

Share this post


Link to post
Share on other sites
32 minutes ago, Tazz said:

Hi everyone! I have a problem with  white colors in game. I already asked for help on this forum discord server but no one knew how to fix this. White color is too bright.I tried turning on/off hdr but it didn't helped.  I think its problem with bloom in enb config file but i don't know what to change in it .Thanks in advance!

e.PNG

Just buy the car or test drive it and you'll see that everything is just fine.

It's a thing of some dealerships to display the colors in a different shade of their real appearance.

Share this post


Link to post
Share on other sites

I have to say, this mod is great, nice work! I've been enjoying it quite a lot.

My biggest nitpick would be the lower quality sounds on some cars, but that is not so easy to change.
What I would like to see tweaked however, is physics on some cars. Most of them feel really good even with keyboard, but there are some that have annoying stability problems on imperfect roads. So far the worst has been the upgraded Lotus Exige S. Zero throttle, just rolling in a straight line, road goes up or down a bit, car slides out and crashes into a tree on its own. I don't know how the game handles suspension and the like, but it feels like the car is too stiff for such low poly roads.
Edit: Oh yeah, one more imperfection I noticed is car groups, some of them are too high or low. I have one example for this, the Audi RS4. I think it should be grouped to D and not E.

Edited by Balathruin

Share this post


Link to post
Share on other sites

Hey guys, new member here.

Been lurking here for several days now and I agree that a wiki styled FAQ would be great to have, especially since I'm having multiple issues with the game myself. I tried the game on both my laptop and desktop computers that I own and there is a huge difference in compatibility. 

First off, I was being heavily frustrated while trying to get the mod to work on my desktop. Many installs and uninstalls and trying out different methods, after which I finally managed to get it to work by removing enbseries config file and d3d9.dll. Otherwise it would just crash immediately without even getting to the main menu. The problem now is that many of the mod's models do not even show up, they are showing up as invisible cars that I can't even select. Is there a fix for that, because I seriously am frustrated at how the mod just refuses to work fine for me. The specs of my PC are above average for gaming with a Haswell i5 4440, GTX 1070 and 8GB of RAM. I'm also using Windows 10 as my main OS.

Strangely enough, I installed the game the same way on my laptop and it works flawlessly there. Didn't have to modify nor remove anything. Of course, deleting those two files that I mentioned previously, the same starts occurring as on my desktop, some models of cars will just outright disappear and refuse to work, even though the game runs fine. Specs are i5 4200H, 8GB of RAM and GTX 850M 2GB DDR3 variant and OS is also Windows 10. 

But the thing is, I really am scratching my head on what could be wrong and why my desktop hates having enbseries with the game. Maybe there is an answer in the previous posts, but I really can't be bothered anymore to search for it.

So, if anyone can help pointing me in the right direction on what could be wrong would be greatly appreciated. 

Share this post


Link to post
Share on other sites
1 hour ago, DaAlcatrax said:
39 minutes ago, DaAlcatrax said:

First off, I was being heavily frustrated while trying to get the mod to work on my desktop. Many installs and uninstalls and trying out different methods, after which I finally managed to get it to work by removing enbseries config file and d3d9.dll. Otherwise it would just crash immediately without even getting to the main menu. The problem now is that many of the mod's models do not even show up, they are showing up as invisible cars that I can't even select. Is there a fix for that, because I seriously am frustrated at how the mod just refuses to work fine for me.

Project Paradise relies in that d3d9.dll, so removing it will obviously break the game. This is what might fix it:

1. Check the file properties for both the Project Paradise Launcher and TestDriveUnlimited executables, make sure no compatibility modes are set.

2. Make sure to exclude the games from your antivirus and/or use CustomD3D support in RTSS/MSI Afterburner if you're using them, same goes for other overlay programs.

Share this post


Link to post
Share on other sites
On 5/6/2019 at 7:27 PM, Mondodimotori said:

 

 

Well, I don't want to make big proclaims, but there is a very good possibility that I solved the issue.

 

Today, after work, I did some more test. A 25 minutes run with the GT86, a car that never presented any problem before. And, after 25 minutes of gameplay, the RAM usage of the game was around 400 mb. No problems whatsoever.

Then I did a second test. I rebooted the game, and switched to the Skyline R32. The first 10 minutes of gameplay went on smooth, with the RAM usage around 300-400 mb. But then, suddenly, the game started eating RAM. 100 mb every 2 minutes, till it reached around 1 GB  of total usage at the 25 minutes mark. And then the FPS tanked. Just like yesterday. The GPu went to 99% of total usage to 20%.

Then my brain started to working. What if the executable can't use more than 1 GB of RAM? That would explain the drop, since the lock on RAM usage would bottleneck the GPU, getting it to perform only 20% of its power.

So I used the legendary (in the rFactor community, at leat) "4 GB Patch". A patch that modify any executable to work without RAM restrictions. 

 

And it worked.

The patch did not comprimised the executable, and I was able to play for an hour straight with my R32, even surpassing that 1 GB mark, and then switching to the AE86 Trueno. No problems, no FPS drops, no nothing. And the game even start being less "hungry" for RAM when it surpass the 1 GB mark, assesting itself around 1.2/1.4 GB of total RAM usage.

 

Someone should give me a little medal for all this testing...

About the "4 GB Patch", you should be able to find it youself on the net. If not, I ask permission to an administrator to post it in this thread, since it could be usefull to more people, and would increment the amount of testing on it, to see if it actually work flawlessly, or my 1 hr run without problems was just dumb luck.

Great work with finding this out man!

However...  I used this patch to Project Paradise Launcher.exe. Started delivery mission with Firebird. 12 km to go, lags again. 😞

Share this post


Link to post
Share on other sites
8 minutes ago, jakub18 said:

Great work with finding this out man!

However...  I used this patch to Project Paradise Launcher.exe. Started delivery mission with Firebird. 12 km to go, lags again. 😞

Because you are supposed to use it on the game exe.

Share this post


Link to post
Share on other sites
1 hour ago, umisery said:

Project Paradise relies in that d3d9.dll, so removing it will obviously break the game. This is what might fix it:

1. Check the file properties for both the Project Paradise Launcher and TestDriveUnlimited executables, make sure no compatibility modes are set.

2. Make sure to exclude the games from your antivirus and/or use CustomD3D support in RTSS/MSI Afterburner if you're using them, same goes for other overlay programs.

Oh damn... the first part was the problem and I can't believe it works now! It's the last thing I would have thought of. 😂

Many thanks!

Edited by DaAlcatrax

Share this post


Link to post
Share on other sites

Hey guys, I'm having a little issue with the 4GB patch, I patched the Testdriverunlimited.exe and after opening Project Paradise and clicking start  the game is giving me a SecuROM™ error, (A required security module cannot be activated.
This program cannot be executed (13000).) Mind you, I'm using my original TDU disc.  

 

Share this post


Link to post
Share on other sites

Updates by TDU Sapphire for TDU Platinum

Platinum mods will be fixed and build new body kits
https://vk.com/tdu_sapphire
Test Drive Unlimited Platinum + 1. Update BMW E82
https://yadi.sk/d/VB2-eXgnnugDHQ


Test Drive Unlimited Platinum + 2. Update Huracan Coupe
https://yadi.sk/d/U3UjRGVxGSZY-w

Test Drive Unlimited Platinum + 3. Update Huracan Spyder
https://yadi.sk/d/KIBHt8fUNB4Y-Q


make sure, that you have made your backup files😉

Edited by Sourkho

Share this post


Link to post
Share on other sites
19 minutes ago, ABC83 said:

Hi!

I can't find some cars, like BMW Z8 or M6 F13 for example.

It's necessary complete some missions to unlock them? 

Thanks. 

They are in the bike shop, near Cadillac. Lol Dealership is a bit packed, but it works, regardless.

Share this post


Link to post
Share on other sites
27 minutes ago, Milli said:

They are in the bike shop, near Cadillac. Lol Dealership is a bit packed, but it works, regardless.

Ah, Ok lol!

Thank's or, obrigado in our language!

Share this post


Link to post
Share on other sites
19 minutes ago, ABC83 said:

And a little offtopic, how can i join a club? 

 

Yes, i'm kind a noob on tdu online 😐

Online features are not working in Project Paradise. Only the free roam. So, you don't join Clubs. Lol

Share this post


Link to post
Share on other sites

"Over 880 vehicles" of which around half of these vehicles are "hidden" on the car list, so whether there are actually over 880 vehicles in the game, or not? I counted all vehicles from all dealerships in game by myself and the result was ~400, so what happened to the rest of those vehicles? Did i need to do something to get them? I can't understand this, maybe because i'm kinda stupid lol. Could someone explain me how does it work? I'll be so grateful 🙂

 

if a similar issue was already been explained in this thread, I'd like to apologize for my inattention.

Edited by Grondzel

Share this post


Link to post
Share on other sites

Cheers for the 1.04 update, this should hopefully now fix my issue of the game tanking in performance than eventually crashing after playing it for a while.

Now if only I could figure out how to get that stupid CH trainer to work again with this! 

Share this post


Link to post
Share on other sites
32 minutes ago, Grondzel said:

"Over 880 vehicles" of which around half of these vehicles are "hidden" on the car list, so whether there are actually over 880 vehicles in the game, or not? I counted all vehicles from all dealerships in game by myself and the result was ~400, so what happened to the rest of those vehicles? Did i need to do something to get them? I can't understand this, maybe because i'm kinda stupid lol. Could someone explain me how does it work? I'll be so grateful 🙂

 

if a similar issue was already been explained in this thread, I'd like to apologize for my inattention.

Spoiler

Large number of cars can be converted in tuning shops. Not all of them are obvious either.

 

Share this post


Link to post
Share on other sites

wiki guide is live now https://turboduck.net/guide/

feel free to start adding question and answers

layout and style are still work in progress

use the test template for messing around with the wiki markups, see https://en.wikipedia.org/wiki/Help:Wikitext

if you're interested adding other guide / Q&A feel free to start new record

if you truely fucked up a record, use restore button to revert back to previous version

 

I can't handle overwork anymore, too tired from work, gonna pass out

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...