Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.
  • 0
MyRide

TDU 2 AMD NAVI/VEGA game not starting

Question

Ok thanks in advance. My last setup playing TDU 2 was on R5 2600X and a GTX 1060 (Windows 10) and everything worked fine not a single crash vanilla or unpacked modded game. After buying Powercolor 5700 XT the game would instantly crash on the first screen (.exe not responding) and same after fresh reinstall of the game.

I read somewhere that after you reach a point where your GPU is new and powerful enough it's no longer TDU 2 for you, is this true? Anyone managed to get this game running with Vega or Navi cards?

The game version I have is v086 build 7. If I remember corretly with 1060 the game was still able to update through the launcher somewhere in 2019 but not it says NAT type Strict.UdpBlocked. No success with universal launcher either instant crash, haven't unpacked the game yet cause it's most likely waste of time. Installed all the files from the redist folder also...

Would be nice to hear if anyone has managed to run this game with newer AMD cards. Nvidia 2000 series seems to have varying success but able to get in game at least. Not a single problem with TDU 1 Platinum (thank god!)

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...