Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.

TDU World :: March 2020 Update!


Recommended Posts

  • 2 weeks later...
  • Replies 89
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Progress is being made behind the scenes. We hope to bring an update soon! 🙂

Hello everyone!   After a while of absence, we are back with a new update with some exciting news.   Coronavirus COVID-19 As most of you know by now, there is a new virus going around the worl

ah, yea that makes sense  

Posted Images

Nice!

I also hope it will be compatible in full with the last generation of graphic cards and their drivers... playing TDU2 with its actual flaws is a real pain nowadays, you know. I tried all the kind of tricks and hints available, but with no results.

And I don't want to go backwards to Win7 and a less performing card either.

With best regards.

Link to post
Share on other sites

Thanks for this, but I was misunderstood, I'm afraid.

I haven't told that TDU was not compatible with Win10.

I said that there are flaws, described in my post and still currently unsolved.  The most annoying, to me, are that I can't see the Ferrari brand in the Italian tuning shop any longer even after applied the proper patch several times, and I can't run some of all championships.

Weird, I was able to before.

That's all.

Oh, well... all the Community here knows well that, just hoping someone can fix this also one day, or better soon.

With best regards.

Edited by JagHond
Link to post
Share on other sites

That's a weird issue @JagHondIt's most likely caused by your TDU2 installation. Hardware doesn't cause things like that.

Are you running a legit version of the game and is it updated to the latest version (DLC2 v034)?

I know plenty of people who use new RTX cards and don't have any issues.

There is, however, one known issue, and that is that opening the map crashes the game. This can be fixed with this .dll (I will attach it to this post). It's called the Vulkan fix, copy it to your TDU2 directory and it should fix that map crashing issue (if you have it).

d3d9.dll

Link to post
Share on other sites
  • 2 weeks later...

But... I still have another 'but' to be solved.

After the last Win 10 Pro updates, why can't I manage to get that blessed Ferrari brand shown on the Italian cars dealer after having installed that 'tdu2 auto pack01' then?

In all my previous installations I got it without any kind of hassle, I remember.

Something is telling me I' better to wait and see that TDU Solar Crown... hoping it will be released, one day.

But anyway it goes, why would such matters happen to me certainly? Bah.

With best regards to all.

Link to post
Share on other sites

So the brand logo is missing from the dealership, is that what you are saying?

It can really only be one thing, a corrupted texture...

What version of AutoPack are you running? If it's 1.85, I would suggest removing it. It's flawed by bugs: cars are missing color options, some are using the wrong rims etc.

Link to post
Share on other sites
18 hours ago, Aquarious said:

So the brand logo is missing from the dealership, is that what you are saying?

It can really only be one thing, a corrupted texture...

What version of AutoPack are you running? If it's 1.85, I would suggest removing it. It's flawed by bugs: cars are missing color options, some are using the wrong rims etc.

I will check and do that way you've suggested to, thanks a lot for your patience with me.

Is its previous version (that one just before 1.85, I mean) running fine or not?

With best regards.

Edited by JagHond
Link to post
Share on other sites
On 10/14/2020 at 1:23 AM, Aquarious said:

So the brand logo is missing from the dealership, is that what you are saying?

It can really only be one thing, a corrupted texture...

What version of AutoPack are you running? If it's 1.85, I would suggest removing it. It's flawed by bugs: cars are missing color options, some are using the wrong rims etc.

Dear Aquarious,

and it's two. Also this last tip you suggested worked out fine.

 

Thanks a lot for your kind attention!

 

With best regards.

Link to post
Share on other sites
On 10/14/2020 at 8:00 PM, JagHond said:

I will check and do that way you've suggested to, thanks a lot for your patience with me.

Is its previous version (that one just before 1.85, I mean) running fine or not?

With best regards.

1.73 works fine, 1.8 also as far as I've heard, but I haven't used that one.

Link to post
Share on other sites

Announcements


×
×
  • Create New...