Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.

TDU Platinum and Logitech G27


Recommended Posts

Hi all.

After 12 year,i found my G27 sleeping in a box and decided to install my old TDU. Then I found the Platinum patch,downloaded and installed.

At the same time,downloaded and installed the G27 patch.

Unfortunately,there is no way to usa the G27.... I checked the "Use wheel" box in the option menu,but no way to have the G27 working.

Any idea / suggestion about and how to fix the problem?

I was thinking to uninstall TDU and reinstall the "normal" version (no platinum patch) and see what happens,but before doing it maybe there is something i can do.....



Link to comment
Share on other sites

Questions0 are never dumb,but the answers (sometimes)

When you say "setup the input settings" do you mean options like "turn right", "accelerete" and so?

If so, i did it, but getting problems like: setting "turn left" then turning the wheel left and getting "left arrow".....

Or setting "accelerate" then pressing the pedals (yep, all...) and getting...nothing

Pluggin in the wheel and then start the game....honestly at this moment i can't answer.... I'm almost sure i started the game the plugged in the wheel....

I'll have a try this evening and post the result.

About TDU supporting the wheel i know it (i've been playing TDU for long time with the wheel),but this time i installed TDU ans patched to platinum directly,so i was wondering if the problem could be the platinum patch.

Question: i suppose you're running windows 10 (at least),like me. For the G27 are you using the standard win drivers (is recognized like G27) or did you find some specific drivers (i tried,but found nothing)?

I'm asking because even if win10 recognizes the wheel as G27,nevertheless if i try to calibrate it,i get no answer from the axis; just the buttons.....

Well, i did as you suggested (connect the wheel then start TDU.

It seems it worked.

Nevertheless,i got problems with the pedals: they don't work.

No way the make the OS (nor TDU) see the pedals .

I checked the pots and the wires,everything seems fine. Used even a contact cleaner on the pots and all the connectors.

Nothing to do...

I wrote to Logitech assistance,let see wath they say (if the answer....)

Edited by Automan
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...