Jump to content
Welcome to the new TurboDuck ! Read more... ×
Sign in to follow this  
Ramon1991cobra

Distant mountains with more quality,

Recommended Posts

When you press the button for the map the distant mountains increase their quality (photo below), but when it is in free ride they go back to see normal (photo above = low poly)

 

If someone is interested (someone with knowledge in hex editing) would be good some modification so that the mountains look better in the distance, but I have no idea how that could be done.

 

30710546_2048340698762694_5272349093467783168_n.jpg?_nc_cat=0&_nc_eui2=v1%3AAeHdLnE1YPjDX5s4ZM6sVoeO12BQs2endwaTTHziHlG9oH5Z5KVz9rvPTQZBGoi9AJ9AKaD4lco0ATgYt3SlwXUxFzcOCVJGoTokF0yARYhxfg&oh=cbace989e4e9d45eb080a9716e8ea360&oe=5B71059F

Share this post


Link to post
Share on other sites

TDU2 probably use the same system as TDU1, so the distant sector (here the moutains) uses the 'Area-x-x-x-x' geometry file instead of the 'Sector-x-x-x-x'.

 

To put it short:

- An Area folder contains several sectors files + a area bnk, which is used as the highest LOD (level of detail) on the map screen and in game (for the farest sector that's not loaded into memory yet)

- A sector acts as the lowest LOD and is (afaik) only used in game. It also contains multiple LOD for sector specific geometry (e.g. lighthouse, ...) as well as an heightmap for the terrain (which is splitted into several patches for tesselation)

 

There might also be a way to edit the way the game streams the sectors (by adding more sectors to be loaded into memory) if it's not hardcoded into the game code. :geek:

Share this post


Link to post
Share on other sites
Well if the game crashes from loading up an AI with a vehicle mod, that most likely means that the "med" quality model is missing from the game files.

In a lot of cases as well it's because mods are missing the BODY_HR object/dummy which can cause issues. I found this out when working on the unofficial patch.

Share this post


Link to post
Share on other sites

I have had that happen with some vehicle mods I tested. Where the med bnk was missing and loading up a race would cause the game to crash (if the AI in the race had the same mod vehicle).

 

Edit:

The game probably crashes from that to prevent the code from going into an infinite loop.

 

Edit 2:

Going off topic, so I will draw a line here...

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×