Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.
TimBud

Speedtest.net is wrong... sortof

Recommended Posts

 

It still annoys me that we have such a pathetic upload in the UK. Carboy's is much better.

 

That's just Virgin being tight pocketed. As soon as BT roll out their fibre network more, Virgin will increase their upload speeds to match that of BT or just a bit higher.

Share this post


Link to post
Share on other sites

Great, only 10 years to wait!

 

It's not just Virgin (I'm not trying to defend them, they are far from saints), the whole lot of them (outside of business) are tight. No one in the thread from the UK has a decent upload.

Share this post


Link to post
Share on other sites
I'm only on a 50kb plan sadly :( $50 a month with phone line bundled.

You are joking me..right? :ill:

 

Then its truth when they say we have some of the most cheap internets in portugal, and hey, great service

for 50€ you can get 200mb Optic Fibre lol.........

I have 12Mb internet(at least i pay for it) and my internet costs around 20€ per month with telephone included!

1246699451.png

 

Notice the slower than 53% of PT^^

Share this post


Link to post
Share on other sites

 

Not bad but I only pay £5 a month so who cares :p

 

I pay $160/75 pounds a month and this is what I get.

 

1246811416.png

 

Compared to some others, the speed is not too bad but the price, well that's in it's own league.

 

The ping is a bit worrying though. It did take ages to load up...

Share this post


Link to post
Share on other sites
I pay $160/75 pounds a month and this is what I get.

 

http://www.speedtest.net/result/1246811416.png

 

Compared to some others, the speed is not too bad but the price, well that's in it's own league.

 

The ping is a bit worrying though. It did take ages to load up...

 

Austin the Ping can also be the router's fault incase its crappy.

When my new internet was installed (12Mb) they installed a Pirelli router, and i had a huge load of PING on online games and servers, and i thought what the hell..better internet, same ISP, cant be the internet line's fault. so tested with my older router, a D-Link, and ping came back to normal :)

Share this post


Link to post
Share on other sites

Patch you are right with the router. It's a crummy ISP provided one so that wouldn't be helping with my ping. I'm getting a new, proper one in a week or so.

 

Not really sure why it picked up the Adelaide server which as you said is millions of miles away. It should have picked up one that is about 150 I'm guessing. Oh well :p

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...