Jump to content
We promise no intrusive ads, Please help keep the community alive
Consider supporting us by disabling your ad blocker / add to whitelist / purchasing VIP.
Milli

[RELEASED] Test Drive Unlimited Platinum

Recommended Posts

9 minutes ago, Djey said:

Simply the hugest and most beautiful tribute to this fantastic game.

Thanks Milli for the effort.

And see you IG all !

Can i like this post more than once? 🤣🤣

Thanks Djey, your help was essential in the times i struggled and without your tools, there wouldn't be a TDU modding community. This is my way to say thank you for your work making it all possible! 

giphy.gif

Share this post


Link to post
Share on other sites
3 minutes ago, ATTRAZION said:

Does the project have a server in the Discord? 

The project itself doesn't have one, but there's TurboDuck Official Discord server though. 
https://discord.gg/FvF6FFv
Anyway, if there is one dedicated the project, lemme know 🙂
Bruh, I'm late.

Edited by Rigel

Share this post


Link to post
Share on other sites
Guest Feri Ara

Thank you Milli for your answers.

I beleive I will have to be a Champion to be able to play Hardcore and to see the g-meter.

About the game I noticed some 1 second freezing from time to time (i7 6700 nvidia 1080Ti OS on a SSD although TDU on a mechanical hardrive) . I beleive it does not occur the second time I play a challenge, so maybe it has to do with loading of maps/textures. Any hint to get rid of the freezing/stuttering besides trying to install TDU on a SSD, that I would like to avoid?

 Thank you

 

Cheers

Share this post


Link to post
Share on other sites
2 minutes ago, Guest Feri Ara said:

Thank you Milli for your answers.

I beleive I will have to be a Champion to be able to play Hardcore and to see the g-meter.

About the game I noticed some 1 second freezing from time to time (i7 6700 nvidia 1080Ti OS on a SSD although TDU on a mechanical hardrive) . I beleive it does not occur the second time I play a challenge, so maybe it has to do with loading of maps/textures. Any hint to get rid of the freezing/stuttering besides trying to install TDU on a SSD, that I would like to avoid?

 Thank you

 

Cheers

Yes you will. The g-meter is only in hardcore mode. 

And no idea about other solution than that, as TDU always did it. 

Share this post


Link to post
Share on other sites

Just opened the database to add my own stuff with TDUF and I be like....
ÐаÑÑинки по запÑоÑÑ wtf face gif

How the hell were you doing in that mess lmfao? Great job and thanks once again cause I doubt anyone else would have the patience to do THAT. 

For other people: run TDUF, open the database and you'll get what I'm talking about (though I understand how it works more or less).

Edited by Rigel

Share this post


Link to post
Share on other sites

Milli (and others who helped make this possible) thanks times infinite for all of your time and great efforts. Looks and feel amazing. So much more fun to be had. This more than 12-year-old game feels like new now. Super awesome! Going to spend so much time in there again. Thanks!!!

Share this post


Link to post
Share on other sites
15 hours ago, Guest Thrasher9294 said:

I actually may have fixed it--I tried applying patch 1.68b and then reinstalling Platinum and it seems to have fixed whatever issue was being caused. I didn't actually use Chrome/Spotify while the issue was happening, and this past session I was able to run Spotify just fine while playing and had no problems!

Cheers for the mod, it's brilliant work. Thanks for getting me introduced to this great game.

First of all, amazing work on the mod @Milli . It really feels like a new game now. 🙂 

I have the exact issue as you did Thrasher, it seems to happen with some cars, one I know for sure has this issue is AE86. After about 20 minutes of gameplay the game just slows down to a crawl, the textures get messed up etc. I have a far less powerful device (940m, i5 5200u, 8gb, pretty basic but TDU runs smooth). I tried doing what you describe. I installed the game, patch 1.66 and megapack. I then Installed the 1.68b patch, which couldn't get installed (I have Polish version), but after installing 1.67d it installed (the game is in English now but I have the original files stored) and then the Platinum. Sadly, the issue is still there. I tried installing 1.68b again over the Platinum, no luck, tried reinstalling Platinum (copied files again and replaced) and still it's starts to slow down after 20 minutes of gameplay. It works perfect up to that point.

Share this post


Link to post
Share on other sites

Thank you so much for this amazing work @Milli, and all the others moders who bring this game so far, TDU feels so fresh now it(s just amazing !

I only have a question about a car in particular, the TVR T440R. Is she gone or did you make it obtainable by tuner shop ? I bought the Tuscan but apart from get out the roof there is nothing lol.

Share this post


Link to post
Share on other sites
4 hours ago, PiotrGT said:

First of all, amazing work on the mod @Milli . It really feels like a new game now. 🙂 

I have the exact issue as you did Thrasher, it seems to happen with some cars, one I know for sure has this issue is AE86. After about 20 minutes of gameplay the game just slows down to a crawl, the textures get messed up etc. I have a far less powerful device (940m, i5 5200u, 8gb, pretty basic but TDU runs smooth). I tried doing what you describe. I installed the game, patch 1.66 and megapack. I then Installed the 1.68b patch, which couldn't get installed (I have Polish version), but after installing 1.67d it installed (the game is in English now but I have the original files stored) and then the Platinum. Sadly, the issue is still there. I tried installing 1.68b again over the Platinum, no luck, tried reinstalling Platinum (copied files again and replaced) and still it's starts to slow down after 20 minutes of gameplay. It works perfect up to that point.

That effect is known to some specific cars, such as the AE86, because the modder who did it, didn't really optmized it for the game.  Sadly, there are no better AE86 mods around, so we must stick with those. But as soon as someone makes one, i suggest the replacement. 

 

3 hours ago, lecatoir said:

Thank you so much for this amazing work @Milli, and all the others moders who bring this game so far, TDU feels so fresh now it(s just amazing !

I only have a question about a car in particular, the TVR T440R. Is she gone or did you make it obtainable by tuner shop ? I bought the Tuscan but apart from get out the roof there is nothing lol.

Still in game, and there are 2 Tuscans... Lol 

Share this post


Link to post
Share on other sites
Guest Thrasher9294
4 hours ago, PiotrGT said:

I have the exact issue as you did Thrasher, it seems to happen with some cars, one I know for sure has this issue is AE86. After about 20 minutes of gameplay the game just slows down to a crawl, the textures get messed up etc. I have a far less powerful device (940m, i5 5200u, 8gb, pretty basic but TDU runs smooth). I tried doing what you describe. I installed the game, patch 1.66 and megapack. I then Installed the 1.68b patch, which couldn't get installed (I have Polish version), but after installing 1.67d it installed (the game is in English now but I have the original files stored) and then the Platinum. Sadly, the issue is still there. I tried installing 1.68b again over the Platinum, no luck, tried reinstalling Platinum (copied files again and replaced) and still it's starts to slow down after 20 minutes of gameplay. It works perfect up to that point. 

Hmm, then certain cars may be the actual cause then--the same time I installed the patch, I also purchased a second vehicle and began using my non-starter cars. My starter car was the Fiat Coupé, and every time I had the slowdown/lag problem it was when driving that car. Since then I've been driving the Nissan Fairlady Z, Volkswagen Corrado, and the NSX Zero (but I only drove that one for around 15 mins before I had to head to work) and haven't had any troubles yet. Strange.

 

Share this post


Link to post
Share on other sites
2 hours ago, Milli said:

That effect is known to some specific cars, such as the AE86, because the modder who did it, didn't really optmized it for the game.  Sadly, there are no better AE86 mods around, so we must stick with those. But as soon as someone makes one, i suggest the replacement.

Wow, well then that explains the issue a person was having last night in the session I was in. I tried to help them go through the motions to try and run the game with elevated permissions and set process priority to high. They had a pretty modern I7 4700K as well as GTX1080. Thus far, I haven't run into any issues with my basic system which is running an FX8350 4ghz 8 core, RX570 and 16GB of GSKILL ram.

Share this post


Link to post
Share on other sites
Guest Thrasher9294
1 hour ago, Anthony817 said:

Wow, well then that explains the issue a person was having last night in the session I was in. I tried to help them go through the motions to try and run the game with elevated permissions and set process priority to high. They had a pretty modern I7 4700K as well as GTX1080. Thus far, I haven't run into any issues with my basic system which is running an FX8350 4ghz 8 core, RX570 and 16GB of GSKILL ram.

Haha, that actually was me Anthony--I was just using LFTRPLLR as my in-game name. I really appreciated the help still, man! And I'd always be down to play again in the future now that we know what's going on.

Share this post


Link to post
Share on other sites
6 hours ago, Milli said:

That effect is known to some specific cars, such as the AE86, because the modder who did it, didn't really optmized it for the game.  Sadly, there are no better AE86 mods around, so we must stick with those. But as soon as someone makes one, i suggest the replacement. 

 

Still in game, and there are 2 Tuscans... Lol 

Damn i bought the Tuscan S, so it was the other one 😂 Thanks for the help, i'm driving to the dealership !

Share this post


Link to post
Share on other sites

Is it possible to create a bug report and/or support thread? I've quite a few but don't want to spam the topic each time I come across one or seem like I'm trying to fault the mod, just constructive criticism to help improve.

Bugs found so far:

Many cars don't have sound in certain views and/or when looking back.

Cockpit cameras for some cars are too close to the steering wheel.

Some manual cars have paddle shift animation for the driver.

Buying any of the "TDU Platinum" cars at the custom dealerships seems to cause random game crashes when opening the map (still have to test and confirm this one), correlation =/= causation 😛 

Share this post


Link to post
Share on other sites
On 4/23/2019 at 12:58 AM, Milli said:

Apparently it has an error, because the database exceeded the 1000 car count. I knew about TDUPE having such error with 1000+ modded TDU, but thought it would be fine as long as i don't make TDUPE read 1000 cars.  But that seems to not be the case.  There is a solution, but it is troublesome. 

- Open TDUPE, mod it as you like.
- Save and close. 
- Open TDU Modding Tools and extract the CarPhysicsData.db from the DB.bnk
- Decrypt it, using TDU UT. 
- Change the total car count to 1105
- Save and close.
- Encrypt it using TDU UT.
- Replace the CarPhysicsData.db with the modded one, inside the DB.bnk
- Run the game. 


Or, you could use TDUF, which in my opinion, once you get used to how it looks, it's a much better and efficient tool. 

Thank's Milli, i will give it a try. 

Share this post


Link to post
Share on other sites
13 hours ago, Guest Thrasher9294 said:

Hmm, then certain cars may be the actual cause then--the same time I installed the patch, I also purchased a second vehicle and began using my non-starter cars. My starter car was the Fiat Coupé, and every time I had the slowdown/lag problem it was when driving that car. Since then I've been driving the Nissan Fairlady Z, Volkswagen Corrado, and the NSX Zero (but I only drove that one for around 15 mins before I had to head to work) and haven't had any troubles yet. Strange.

For what it's worth, I've made a list back in 2018 of the cars I had played with through UCP, listing which ones had lag (including their severity), and which didn't. We should all combinate to make a list of which cars are known to be laggy, so people can avoid them. 😛

Edited by Tadpole

Share this post


Link to post
Share on other sites
10 hours ago, umisery said:

Is it possible to create a bug report and/or support thread? I've quite a few but don't want to spam the topic each time I come across one or seem like I'm trying to fault the mod, just constructive criticism to help improve.

Bugs found so far:

Many cars don't have sound in certain views and/or when looking back.

Cockpit cameras for some cars are too close to the steering wheel.

Some manual cars have paddle shift animation for the driver.

Buying any of the "TDU Platinum" cars at the custom dealerships seems to cause random game crashes when opening the map (still have to test and confirm this one), correlation =/= causation 😛 

Which vehicles are missing the sounds? So i can check them out.

Cockpit cameras are not a bug, if i bring the camera further back, you will see a headless neck appearing in your screen... so, yeah, no.  To fix that only unlocking the car file .bnk. 

Also, which cars that are manual that have paddle shift animation? 

TDU Platinum cars are not really meant to be driven in that form. Lol 

Share this post


Link to post
Share on other sites
15 minutes ago, Milli said:

...
Cockpit cameras are not a bug, if i bring the camera further back, you will see a headless neck appearing in your screen... so, yeah, no.  To fix that only unlocking the car file .bnk. 
....

In the Options > Game Settings > Seat Position he could can change highs and lows. My seat was too close there.

Share this post


Link to post
Share on other sites
3 minutes ago, MagicV8 said:

In the Options > Game Settings > Seat Position he could can change highs and lows. My seat was too close there.

Also helps. But some cars really had to get a "closer" view.  I tested all the cameras in the lowest and further back possible in the "Seat Position" menu, to really avoid the headless neck from appearing on screen. Lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...